ニュース

EC-CUBE 4.1 対応プラグイン申請受付開始のお知らせ(2021/07/08)

次期最新版 EC-CUBE 4.1 RC のリリースに先立ちまして、EC-CUBE 4.1 対応プラグインの開発を行っていただけるよう、 EC-CUBE 4.1 対応プラグインの申請受付を開始しました。
プラグイン制作者の方は、以下をご確認いただき申請いただけますようお願いいたします。

■プラグインの申請方法

オーナーズストアのパートナーマイページよりプラグインを申請時に「対応しているEC-CUBEバージョン」として「4.1.0」を選択し、申請をお願いいたします。

申請いただきました EC-CUBE 4.1 対応プラグインの承認は EC-CUBE 4.1 RC リリース後に開始予定です。 EC-CUBE 4.0 対応プラグインで承認を急がれる方は EC-CUBE 4.0 対応プラグインとして申請をお願いいたします。

■プラグインの4.1対応及びテスト方法について

EC-CUBE 4.0 対応プラグインの EC-CUBE 4.1 対応については開発ドキュメントの「EC-CUBE4.0から4.1へのマイグレーション」のページをご確認ください。

EC-CUBE 4.1 RC リリースまでに認証キーを用いたオーナーズストア経由でのプラグインインストールのテストをされたい場合は、開発ドキュメントの「EC-CUBE4.0から4.1へのマイグレーション」のページに記載の方法で EC-CUBE 4.1 の設定変更をしてテストをお願いします。
EC-CUBE 4.1 RC では設定変更不要でテストが可能となる予定です。

■注意事項

2021/07/08 時点で EC-CUBE 4.0 とEC-CUBE 4.1 の両方に対応するプラグインを申請いただいた場合、EC-CUBE 4.0 でのインストールでエラーとなる問題が発生しています。EC-CUBE 4.0 とEC-CUBE 4.1 の両方対応のプラグインでご準備いただいている場合は申請いただきましても EC-CUBE 4.0 でのインストールのテストはできません。こちらの問題が解決致しましたらお知らせを更新させていただきますので、改めてインストールのテストなど行っていただきますようよろしくお願いいたします。


■関連リンク

EC-CUBE 4.1 beta 2
EC-CUBE 4.1 Roadmap #4603
EC-CUBE 4.1 機能開発方針 #4901
EC-CUBE 4.1 リリース延期のお知らせ


引き続き、皆様のご協力を何卒よろしくお願いいたします。