脆弱性

ディレクトリトラバーサルの脆弱性(4.0系)

  • 情報公開日:2020年 06月 17日
  • 危険度:中
  • 対象:Ver 4.0.0〜4.0.3
EC-CUBE4.0系にディレクトリトラバーサルの脆弱性が報告されました。

※2020年6月17日にリリースしました最新版のEC-CUBE 4.0.4では、本件の脆弱性は修正されております。

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
脆弱性の概要 
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ディレクトリトラバーサルの脆弱性

危険度: 中
不具合が存在するEC-CUBEのバージョン: 4.0.0〜4.0.3

管理画面の商品登録機能を利用して任意のパスのファイル・ディレクトリの削除が行える可能性があります。
なお、実行には管理画面にログインし、サーバー内のファイル・ディレクトリの削除権限を持つユーザーでEC-CUBEが実行されている必要があります。

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
修正方法について
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
今回の脆弱性は「EC-CUBEのバージョンアップ」または「修正ファイルの適用」により解決することができます。
以下いずれかの方法で、修正をお願い致します。

修正方法1: EC-CUBEを4.0.4以降にバージョンアップする
修正方法2: 修正用の差分ファイルを利用する
修正方法3: 修正箇所のソースコード差分を確認し必要に応じて適用する

修正方法の詳細・修正ファイルの入手は、下記のサイトをご確認ください。
https://www.ec-cube.net/info/weakness/20200609/

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
謝辞
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
本件の情報は、株式会社シルクロード様 よりご提供いただきました。
この場をお借りして、厚く御礼申し上げます。

EC-CUBE® DemoSite

デモサイトで体験

最新ニュースやECノウハウをお届けします
メールマガジン登録はコチラ