EC-CUBE 4.0 Web API プラグイン

EC-CUBE 4.0 Web API プラグインプラグイン

ダウンロード無料

ダウンロード数: 13

★★★★★0件の評価

公開日: 2020年9月15日 / 更新日: 2020年9月15日

対応バージョン: 4.0.5以上
4.0系4.0.5

提供:株式会社イーシーキューブ

サポート: 開発コミュニティ

ライセンス: LGPL

商品情報

【PHP7.2以上必須】EC-CUBE 4.0 Web API プラグインです。OAuth2.0 による認可、 GraphQL による取得と更新および Webhook による通知が可能です。拡張機構を備えていますので、必要に応じてAPIを追加/カスタマイズしてご利用いただけます。

EC-CUBE 4.0 対応の Web API プラグインです。

EC-CUBE4 Web API プラグイン 開発ドキュメントはこちら

EC-CUBE 4.0 Web API プラグイン

実装機能

・OAuth2.0 による認可
  ・Authorization Code Grant をサポート

・GraphQL による取得と更新
  ・商品情報の取得(単品/一覧)
  ・受注情報の取得(単品/一覧)
  ・会員情報の取得(単品/一覧)
  ・商品在庫の更新
  ・出荷ステータスの更新

・Webhook による通知
  ・商品情報
  ・受注情報
  ・会員情報

・拡張機構
  ・取得可能なデータの追加
  ・Query/Mutationの追加

OAuth管理

EC-CUBE 4.0 Web API プラグイン

WebHook管理

EC-CUBE 4.0 Web API プラグイン

GraphQL

EC-CUBE 4.0 Web API プラグイン

動作確認環境

・PHP 7.2 or higher
・PostgreSQL or MySQL
・EC-CUBE 4.0.5 or higher
・SSLサーバー証明書(TLS) は必須

詳しくはEC-CUBE4 Web API プラグイン 開発ドキュメントをご確認ください。

開発ご協力へのお礼

本プラグインをリリースするに際し、沢山の企業、団体、コミュニティおよび開発者に支援、ご協力をいただきました。ありがとうございます。

PAGE TOP

リリースノート

EC-CUBE 4.0 対応の Web API プラグイン 1.0.0 をリリースいたしました。(2020/09/15)
EC-CUBE 4.0 対応の Web API プラグイン 1.0.0 をリリースいたしました。

リリースに際し、沢山のご協力をいただきました。ありがとうございます。

PAGE TOP

EC-CUBE 4.0 Web API プラグインダウンロード無料

この商品に対するお客様の声

この商品に対するご感想をぜひお寄せください。

PAGE TOP